Specifications (for when you want the truth)
- RFC 9293 — TCP. Published August 2022; replaced RFC 793 (1981).
- RFC 8200 — IPv6.
- RFC 1918 — private address ranges. Two pages.
- RFC 826 — ARP. Three pages, and a good first RFC.
- RFC 2131 — DHCP.
- RFC 1034 / 1035 — DNS.
- RFC 9110–9114 — HTTP semantics, HTTP/1.1, HTTP/2, HTTP/3.
- RFC 9000 — QUIC.
Read RFCs at rfc-editor.org or datatracker.ietf.org.